summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorThomas Vander Stichele <thomas@apestaart.org>2004-02-06 13:09:35 +0000
committerThomas Vander Stichele <thomas@apestaart.org>2004-02-06 13:09:35 +0000
commit189413f070d92777d72906fd5ff3fc2a70be61ff (patch)
treefca522ee9ef973c122e72d7dec779ee3b6811415 /Makefile.am
parent0d71d34f1246fd9d9a1f64d337fe08ccc0af4a3d (diff)
remove RELEASE
Original commit message from CVS: remove RELEASE
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am17
1 files changed, 16 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 97ba31f2..e44fed0a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -35,11 +35,26 @@ DIST_SUBDIRS=ext gst-libs \
pkgconfig
EXTRA_DIST=gst-plugins.spec depcomp \
- AUTHORS COPYING COPYING.LIB README RELEASE REQUIREMENTS \
+ AUTHORS COPYING COPYING.LIB README REQUIREMENTS \
ChangeLog autogen.sh common m4
DISTCLEANFILES=_stdint.h
+# to do a release, run "make release"
+# this will generate all archives and md5sums
+
+# make bz2 as well
+AUTOMAKE_OPTIONS = dist-bzip2
+
+release: dist
+ make @PACKAGE@-@VERSION@.tar.gz.md5
+ make @PACKAGE@-@VERSION@.tar.bz2.md5
+
+# generate md5 sum files
+%.md5: %
+ md5sum $< > $@
+
+
dist-hook:
rm -rf `find $(distdir)/common -name CVS`
rm -rf `find $(distdir)/m4 -name CVS`