summaryrefslogtreecommitdiff
path: root/pkgconfig/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'pkgconfig/meson.build')
-rw-r--r--pkgconfig/meson.build33
1 files changed, 33 insertions, 0 deletions
diff --git a/pkgconfig/meson.build b/pkgconfig/meson.build
new file mode 100644
index 000000000..3356936e1
--- /dev/null
+++ b/pkgconfig/meson.build
@@ -0,0 +1,33 @@
+pkgconf = configuration_data()
+
+pkgconf.set('prefix', get_option('prefix'))
+pkgconf.set('exec_prefix', '${prefix}')
+pkgconf.set('libdir', '${prefix}/@0@'.format(get_option('libdir')))
+pkgconf.set('includedir', '${prefix}/@0@'.format(get_option('includedir')))
+pkgconf.set('GST_API_VERSION', api_version)
+pkgconf.set('VERSION', gst_version)
+
+pkg_install_dir = '@0@/pkgconfig'.format(get_option('libdir'))
+
+pkg_libs = [
+ 'bad-audio',
+ 'bad-base',
+ 'bad-video',
+ 'codecparsers',
+ # Broken and not built currently
+ #'gl',
+ 'insertbin',
+ 'mpegts',
+ 'player',
+ 'plugins-bad',
+]
+
+# FIXME: -uninstalled.pc files (if still needed?)
+foreach p : pkg_libs
+ infile = 'gstreamer-@0@.pc.in'.format(p)
+ outfile = 'gstreamer-@0@-@1@.pc'.format(p, api_version)
+ configure_file(input : infile,
+ output : outfile,
+ configuration : pkgconf,
+ install_dir : pkg_install_dir)
+endforeach