summaryrefslogtreecommitdiff
path: root/tests/examples/Makefile.am
diff options
context:
space:
mode:
authorThiago Santos <thiago.sousa.santos@collabora.co.uk>2010-12-06 11:05:17 -0300
committerThiago Santos <thiago.sousa.santos@collabora.co.uk>2010-12-08 15:38:30 -0300
commitf62e658c10fc011fba5ce5eede79ac09df6a74e2 (patch)
tree1b72acdc1ac3f4638c46f92ecfba58929da681de /tests/examples/Makefile.am
parentdb72d691caa0d37409fb684aa5d291ab1977d34b (diff)
camerabin2: Only run tests if experimental is enabled
Only run camerabin2 tests and build examples if experimental plugins are enabled
Diffstat (limited to 'tests/examples/Makefile.am')
-rw-r--r--tests/examples/Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/tests/examples/Makefile.am b/tests/examples/Makefile.am
index 218f2c622..dbd11934c 100644
--- a/tests/examples/Makefile.am
+++ b/tests/examples/Makefile.am
@@ -15,5 +15,11 @@ else
DIRECTFB_DIR=
endif
+if BUILD_EXPERIMENTAL
+CAMERABIN2=camerabin2
+else
+CAMERABIN2=
+endif
+
SUBDIRS= $(DIRECTFB_DIR) $(GTK_EXAMPLES) $(JACK_EXAMPLES) switch
-DIST_SUBDIRS= camerabin camerabin2 directfb jack mxf scaletempo switch
+DIST_SUBDIRS= camerabin $(CAMERABIN2) directfb jack mxf scaletempo switch