summaryrefslogtreecommitdiff
path: root/tests/examples/Makefile.am
diff options
context:
space:
mode:
authorGeorge Kiagiadakis <george.kiagiadakis@collabora.com>2015-10-26 16:24:40 +0100
committerGeorge Kiagiadakis <george.kiagiadakis@collabora.com>2015-11-18 13:10:45 +0100
commit3eeec2836a8f1ddb5525633f4ae1c360ddc9d3ba (patch)
tree19daca6c4a48c145fcde9c4049fd220bb2f4201e /tests/examples/Makefile.am
parentc51fe83d4228262f297382f49676c76cd2f8147e (diff)
tests/examples: add a waylandsink example
https://bugzilla.gnome.org/show_bug.cgi?id=748322
Diffstat (limited to 'tests/examples/Makefile.am')
-rw-r--r--tests/examples/Makefile.am15
1 files changed, 13 insertions, 2 deletions
diff --git a/tests/examples/Makefile.am b/tests/examples/Makefile.am
index c26d3d9fd..57ed6ddc3 100644
--- a/tests/examples/Makefile.am
+++ b/tests/examples/Makefile.am
@@ -40,6 +40,16 @@ else
GTK3_DIR=
endif
+if USE_WAYLAND
+if HAVE_GTK3
+WAYLAND_DIR=waylandsink
+else
+WAYLAND_DIR=
+endif
+else
+WAYLAND_DIR=
+endif
+
noinst_PROGRAMS = playout
playout_SOURCES = playout.c
@@ -47,7 +57,8 @@ playout_CFLAGS = $(GST_PLUGINS_BASE_CFLAGS) $(GST_CFLAGS)
playout_LDADD = $(GST_PLUGINS_BASE_LIBS) -lgstvideo-$(GST_API_VERSION) $(GST_LIBS)
SUBDIRS= codecparsers mpegts $(DIRECTFB_DIR) $(GTK_EXAMPLES) $(OPENCV_EXAMPLES) \
- $(GL_DIR) $(GTK3_DIR) $(AVSAMPLE_DIR)
-DIST_SUBDIRS= codecparsers mpegts camerabin2 directfb mxf opencv uvch264 gl gtk avsamplesink
+ $(GL_DIR) $(GTK3_DIR) $(AVSAMPLE_DIR) $(WAYLAND_DIR)
+DIST_SUBDIRS= codecparsers mpegts camerabin2 directfb mxf opencv uvch264 gl gtk \
+ avsamplesink waylandsink
include $(top_srcdir)/common/parallel-subdirs.mak