summaryrefslogtreecommitdiff
path: root/tests/check/Makefile.am
diff options
context:
space:
mode:
authorAndre Guedes <andre.guedes@intel.com>2019-05-02 10:52:42 -0700
committerEderson de Souza <ederson.desouza@intel.com>2019-07-03 09:59:35 -0700
commitc427fd1aec4f1bf07f7677a060f210c8a5a3d42a (patch)
treecb2e4270a69cd10491ff4163b98b99b7164f33e2 /tests/check/Makefile.am
parente0deddbcf6215cfa3f270abab5426fc6bdfd41b2 (diff)
tests: Add AVTP source tests
This patch adds test cases for the AVTP source element. For now, only properties get() and set() are covered.
Diffstat (limited to 'tests/check/Makefile.am')
-rw-r--r--tests/check/Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/tests/check/Makefile.am b/tests/check/Makefile.am
index 513b85fd2..8df723716 100644
--- a/tests/check/Makefile.am
+++ b/tests/check/Makefile.am
@@ -40,7 +40,7 @@ check_assrender =
endif
if USE_AVTP
-check_avtp = elements/avtpaafpay elements/avtpaafdepay elements/avtpsink
+check_avtp = elements/avtpaafpay elements/avtpaafdepay elements/avtpsink elements/avtpsrc
else
check_avtp =
endif
@@ -513,6 +513,9 @@ elements_avtpaafdepay_LDADD = $(GST_PLUGINS_BASE_LIBS) $(GST_BASE_LIBS) $(LDADD)
elements_avtpsink_CFLAGS = $(GST_PLUGINS_BASE_CFLAGS) $(GST_BASE_CFLAGS) $(AM_CFLAGS)
elements_avtpsink_LDADD = $(GST_PLUGINS_BASE_LIBS) $(GST_BASE_LIBS) $(LDADD)
+elements_avtpsrc_CFLAGS = $(GST_PLUGINS_BASE_CFLAGS) $(GST_BASE_CFLAGS) $(AM_CFLAGS)
+elements_avtpsrc_LDADD = $(GST_PLUGINS_BASE_LIBS) $(GST_BASE_LIBS) $(LDADD)
+
elements_mpegtsmux_CFLAGS = $(GST_PLUGINS_BASE_CFLAGS) $(GST_BASE_CFLAGS) $(AM_CFLAGS)
elements_mpegtsmux_LDADD = $(GST_PLUGINS_BASE_LIBS) $(GST_VIDEO_LIBS) $(GST_BASE_LIBS) $(LDADD)