summaryrefslogtreecommitdiff
path: root/tests/check/Makefile.am
diff options
context:
space:
mode:
authorVivia Nikolaidou <vivia@ahiru.eu>2018-07-19 18:34:40 +0300
committerVivia Nikolaidou <vivia@ahiru.eu>2018-07-24 13:20:59 +0300
commit854baf4fdbff7a69aee82648f1e064a49c74a1ac (patch)
treeb3ea608a725b644b6502ba7072acff7bb9abc5e9 /tests/check/Makefile.am
parentb0ae6a522186d5c123612eedc847b04eeeed6b65 (diff)
avwait: Add recording property
It works like a valve in front of the actual avwait. When recording == TRUE, other rules are then examined. When recording == FALSE, nothing is passing through. https://bugzilla.gnome.org/show_bug.cgi?id=796836
Diffstat (limited to 'tests/check/Makefile.am')
-rw-r--r--tests/check/Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/tests/check/Makefile.am b/tests/check/Makefile.am
index 163ef068e..b54d8780c 100644
--- a/tests/check/Makefile.am
+++ b/tests/check/Makefile.am
@@ -257,6 +257,7 @@ check_PROGRAMS = \
elements/videoframe-audiolevel \
elements/autoconvert \
elements/autovideoconvert \
+ elements/avwait \
elements/asfmux \
elements/camerabin \
elements/gdppay \
@@ -403,6 +404,13 @@ elements_videoframe_audiolevel_LDADD = \
$(GST_PLUGINS_BASE_LIBS) $(GST_BASE_LIBS) $(GST_LIBS) $(LDADD) \
$(GST_AUDIO_LIBS)
+elements_avwait_CFLAGS = \
+ $(GST_PLUGINS_BASE_CFLAGS) \
+ $(GST_BASE_CFLAGS) $(GST_CFLAGS) $(AM_CFLAGS)
+elements_avwait_LDADD = \
+ $(GST_PLUGINS_BASE_LIBS) $(GST_BASE_LIBS) $(GST_LIBS) $(LDADD) \
+ $(GST_AUDIO_LIBS) $(GST_VIDEO_LIBS)
+
elements_faad_CFLAGS = \
$(GST_PLUGINS_BASE_CFLAGS) \
$(GST_BASE_CFLAGS) $(GST_CFLAGS) $(AM_CFLAGS)