summaryrefslogtreecommitdiff
path: root/tests/check/Makefile.am
diff options
context:
space:
mode:
authorSebastian Dröge <sebastian@centricular.com>2018-11-02 12:21:45 +0200
committerSebastian Dröge <sebastian@centricular.com>2018-11-02 12:22:15 +0200
commitfca02f3dac15987502dde6439bd09b6537eca604 (patch)
tree855a273de0d0a4b28edb5b2b6c70efa864364263 /tests/check/Makefile.am
parent7cfe6b0bf3404fb000d3d0a57a24ffcae9062ee8 (diff)
ccextractor: Add unit test
https://bugzilla.gnome.org/show_bug.cgi?id=797370
Diffstat (limited to 'tests/check/Makefile.am')
-rw-r--r--tests/check/Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/tests/check/Makefile.am b/tests/check/Makefile.am
index c6e86d4b3..a1061a93c 100644
--- a/tests/check/Makefile.am
+++ b/tests/check/Makefile.am
@@ -40,6 +40,12 @@ else
check_assrender =
endif
+if USE_PANGO
+check_ccextractor = elements/ccextractor
+else
+check_ccextractor =
+endif
+
if USE_DASH
check_dash = elements/dash_mpd
check_dash_demux = elements/dash_demux
@@ -240,6 +246,7 @@ noinst_PROGRAMS = \
check_PROGRAMS = \
generic/states \
$(check_assrender) \
+ $(check_ccextractor) \
$(check_dash) \
$(check_dtls) \
$(check_faac) \
@@ -451,6 +458,9 @@ elements_camerabin_LDADD = \
$(GST_BASE_LIBS) $(GST_LIBS) $(LDADD)
elements_camerabin_SOURCES = elements/camerabin.c
+elements_ccextractor_CFLAGS = $(GST_PLUGINS_BASE_CFLAGS) $(GST_BASE_CFLAGS) $(AM_CFLAGS)
+elements_ccextractor_LDADD = $(GST_PLUGINS_BASE_LIBS) $(GST_VIDEO_LIBS) $(GST_BASE_LIBS) $(LDADD)
+
elements_jifmux_CFLAGS = $(GST_PLUGINS_BASE_CFLAGS) $(EXIF_CFLAGS) $(AM_CFLAGS)
elements_jifmux_LDADD = $(GST_PLUGINS_BASE_LIBS) -lgsttag-$(GST_API_VERSION) $(GST_CHECK_LIBS) $(EXIF_LIBS) $(LDADD)
elements_jifmux_SOURCES = elements/jifmux.c