summaryrefslogtreecommitdiff
path: root/docs/Makefile.am
diff options
context:
space:
mode:
authorJan Schmidt <thaytan@mad.scientist.com>2008-05-16 19:56:30 +0000
committerJan Schmidt <thaytan@mad.scientist.com>2008-05-16 19:56:30 +0000
commitd5641e3e6b8d4a665431f20e077873b8016bbb1d (patch)
tree12fec2047a36c1d384678c618832b118d2e99513 /docs/Makefile.am
parent363d6a265272e906892f78b86a2d76f10b0528d6 (diff)
docs/Makefile.am: Don't attempt to build plugin docs when they're disabled.
Original commit message from CVS: * docs/Makefile.am: Don't attempt to build plugin docs when they're disabled. * gst/bayer/Makefile.am: Add libgstvideo to the link. * gst/rtpmanager/Makefile.am: Fix link order, and move LIBS things to _LIBS
Diffstat (limited to 'docs/Makefile.am')
-rw-r--r--docs/Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/docs/Makefile.am b/docs/Makefile.am
index 2b9075b79..762d93b20 100644
--- a/docs/Makefile.am
+++ b/docs/Makefile.am
@@ -1,5 +1,11 @@
+if ENABLE_PLUGIN_DOCS
+PLUGIN_DOCS_DIRS = plugins
+else
+PLUGIN_DOCS_DIRS =
+endif
+
if ENABLE_GTK_DOC
-GTK_DOC_DIRS = plugins
+GTK_DOC_DIRS = $(PLUGINS_DOCS_DIRS)
else
GTK_DOC_DIRS =
endif