summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorThiago Santos <thiago.sousa.santos@collabora.com>2012-11-08 15:42:39 -0300
committerThiago Santos <thiago.sousa.santos@collabora.com>2013-05-07 20:02:41 -0300
commitef25e05b7cd6be35f9473545e22d15ef44591c1f (patch)
tree4daf914d1257529c79e5c35ac2edcae7ddf37b0a /configure.ac
parentf0211e5b7b55d607086bbdb7458981f9a551c661 (diff)
smoothstreaming: build directory stubs for new plugin
Initial build structure for MS' Smooth Streaming plugin Conflicts: ext/Makefile.am
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 14 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 1d31c1e70..6eba5b743 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1926,6 +1926,18 @@ AG_GST_CHECK_FEATURE(SDL, [SDL plug-in], sdlvideosink sdlaudiosink, [
AM_PATH_SDL(, HAVE_SDL=yes, HAVE_SDL=no)
])
+dnl **** Smooth Streaming ****
+translit(dnm, m, l) AM_CONDITIONAL(USE_SMOOTHSTREAMING, true)
+AG_GST_CHECK_FEATURE(SMOOTHSTREAMING, [Smooth Streaming plug-in], smoothstreaming, [
+ PKG_CHECK_MODULES(LIBXML2, libxml-2.0 >= 2.4,
+ [HAVE_LIBXML2="yes"
+ HAVE_SMOOTHSTREAMING="yes"],
+ [HAVE_LIBXML2="no"
+ HAVE_SMOOTHSTREAMING="no"])
+ AC_SUBST(LIBXML2_CFLAGS)
+ AC_SUBST(LIBXML2_LIBS)
+])
+
dnl *** sndfile ***
translit(dnm, m, l) AM_CONDITIONAL(USE_SNDFILE, true)
AG_GST_CHECK_FEATURE(SNDFILE, [sndfile plug-in], sfsrc sfsink, [
@@ -2230,6 +2242,7 @@ AM_CONDITIONAL(USE_RSVG, false)
AM_CONDITIONAL(USE_TIMIDITY, false)
AM_CONDITIONAL(USE_WILDMIDI, false)
AM_CONDITIONAL(USE_SDL, false)
+AM_CONDITIONAL(USE_SMOOTHSTREAMING, false)
AM_CONDITIONAL(USE_SNDFILE, false)
AM_CONDITIONAL(USE_SOUNDTOUCH, false)
AM_CONDITIONAL(USE_SPANDSP, false)
@@ -2492,6 +2505,7 @@ ext/rtmp/Makefile
ext/sbc/Makefile
ext/schroedinger/Makefile
ext/sdl/Makefile
+ext/smoothstreaming/Makefile
ext/sndfile/Makefile
ext/soundtouch/Makefile
ext/spandsp/Makefile