summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTim-Philipp Müller <tim@centricular.net>2013-04-01 22:38:52 +0100
committerTim-Philipp Müller <tim@centricular.net>2013-04-01 22:39:23 +0100
commitbd175c4bae591084b168bd33b2e4704440ae37b1 (patch)
tree5e2794617bff96c6cffe394c04d2e029c30e962d /configure.ac
parentacf06f602d89cd01238994c343c9c4b236fa2af2 (diff)
configure: also check for bluez for bluetooth/bluetooth.h
Fixes build on machines where bluez headers are not available.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 6 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 49eab8801..2c0c1e5d0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -844,8 +844,12 @@ fi
dnl *** bluez ***
translit(dnm, m, l) AM_CONDITIONAL(USE_BLUEZ, true)
AG_GST_CHECK_FEATURE(BLUEZ, [Bluez], bluez, [
- dnl FIXME: we should be able to replace this with the GLib DBus stuff
- PKG_CHECK_MODULES([DBUS], [dbus-1], [HAVE_BLUEZ=yes], [HAVE_BLUEZ=no])
+ PKG_CHECK_MODULES([BLUEZ], [bluez < 5.0], [
+ dnl FIXME: we should be able to replace this with the GLib DBus stuff
+ PKG_CHECK_MODULES([DBUS], [dbus-1], [HAVE_BLUEZ=yes], [HAVE_BLUEZ=no])
+ ], [
+ HAVE_BLUEZ=no
+ ])
])
dnl *** OS X videosrc ***