summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorThiago Santos <thiago.sousa.santos@collabora.com>2013-04-15 17:43:56 -0300
committerThiago Santos <thiago.sousa.santos@collabora.com>2013-04-16 15:58:13 -0300
commit2a877b072bae9219f4d759e224b475fd45164aad (patch)
tree83578840d0bac30b1807ff48e05caed8eff016b9 /configure.ac
parent2910613e4a70c5b432403f2ec64506fa42f42bba (diff)
eagl: add ios window system option for eglgles configure
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 10 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 033e0d247..443a70342 100644
--- a/configure.ac
+++ b/configure.ac
@@ -448,7 +448,7 @@ fi
dnl *** gst-libs/gst/egl ***
AC_ARG_WITH([egl-window-system],
- AS_HELP_STRING([--with-egl-window-system],[EGL window system to use (x11, mali-fb, rpi, none)]),
+ AS_HELP_STRING([--with-egl-window-system],[EGL window system to use (x11, mali-fb, rpi, ios, none)]),
[EGL_WINDOW_SYSTEM="$withval"],
[EGL_WINDOW_SYSTEM="auto"])
@@ -484,6 +484,12 @@ if test x"$EGL_WINDOW_SYSTEM" = x"auto"; then
fi
if test x"$EGL_WINDOW_SYSTEM" = x"auto"; then
+ if test x"$HAVE_IOS" = x"yes"; then
+ EGL_WINDOW_SYSTEM="ios"
+ fi
+ fi
+
+ if test x"$EGL_WINDOW_SYSTEM" = x"auto"; then
EGL_WINDOW_SYSTEM="none"
fi
fi
@@ -589,6 +595,9 @@ case "$EGL_WINDOW_SYSTEM" in
LIBS=$old_LIBS
CFLAGS=$old_CFLAGS
;;
+ ios)
+ HAVE_EGLGLES="yes"
+ ;;
*)
AC_MSG_ERROR([invalid EGL window system specified])
;;