summaryrefslogtreecommitdiff
path: root/fc-case/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'fc-case/Makefile.am')
-rw-r--r--fc-case/Makefile.am52
1 files changed, 52 insertions, 0 deletions
diff --git a/fc-case/Makefile.am b/fc-case/Makefile.am
new file mode 100644
index 0000000..e00508b
--- /dev/null
+++ b/fc-case/Makefile.am
@@ -0,0 +1,52 @@
+#
+# $Id $
+#
+# Copyright © 2003 Keith Packard
+#
+# Permission to use, copy, modify, distribute, and sell this software and its
+# documentation for any purpose is hereby granted without fee, provided that
+# the above copyright notice appear in all copies and that both that
+# copyright notice and this permission notice appear in supporting
+# documentation, and that the name of Keith Packard not be used in
+# advertising or publicity pertaining to distribution of the software without
+# specific, written prior permission. Keith Packard makes no
+# representations about the suitability of this software for any purpose. It
+# is provided "as is" without express or implied warranty.
+#
+# KEITH PACKARD DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE,
+# INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS, IN NO
+# EVENT SHALL KEITH PACKARD BE LIABLE FOR ANY SPECIAL, INDIRECT OR
+# CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE,
+# DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER
+# TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR
+# PERFORMANCE OF THIS SOFTWARE.
+#
+
+INCLUDES=-I${top_srcdir}/src -I${top_srcdir} $(FREETYPE_CFLAGS) $(WARN_CFLAGS)
+
+TMPL=fccase.tmpl.h
+STMPL=${top_srcdir}/fc-case/${TMPL}
+TARG=fccase.h
+
+noinst_PROGRAMS=fc-case
+
+noinst_HEADERS=$(TARG)
+
+noinst_MANS=fc-case.man
+
+fc_case_SRCS= \
+ fc-case.c \
+ fccaseint.h \
+ fccaseread.c
+
+CASEFOLDING=CaseFolding.txt
+SCASEFOLDING=${top_srcdir}/fc-case/CaseFolding.txt
+
+EXTRA_DIST=$(TMPL) $(CASEFOLDING)
+
+$(TARG): $(STMPL) fc-case $(SCASEFOLDING)
+ rm -f $(TARG)
+ ./fc-case $(SCASEFOLDING) < $(STMPL) > $(TARG)
+
+CLEANFILES=$(TARG)
+