summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gmail.com>2013-10-10 20:54:25 -0700
committerMatt Turner <mattst88@gmail.com>2013-10-14 11:33:02 -0700
commitcd460f1a2c5c23bacfb6849923f5d4596ebc3fc4 (patch)
treea9417bb7fd0778d43e220d0ec8d0bab8c4b939fa /configure.ac
parentd3d371fdf6aab3433ffe4bdf1d7512245aa26335 (diff)
configure: Don't bail if libdrm_nouveau isn't available.
We were seriously *requiring* libdrm_nouveau unless explicitly disabled? Acked-by: Ben Widawsky <ben@bwidawsk.net> Reviewed-by: Chad Versace <chad.versace@linux.intel.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 5 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 741dd7499..9777bccb0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -107,8 +107,11 @@ AM_CONDITIONAL(BUILD_ASSEMBLER, [test "x$enable_assembler" = xyes])
# -----------------------------------------------------------------------------
# for dma-buf tests
AC_ARG_ENABLE(nouveau, AS_HELP_STRING([--disable-nouveau],
- [Enable use of nouveau API for prime tests (default: enabled)]),
- [NOUVEAU=$enableval], [NOUVEAU=yes])
+ [Enable use of nouveau API for prime tests (default: auto)]),
+ [NOUVEAU=$enableval], [NOUVEAU=auto])
+if test "x$NOUVEAU" = xauto; then
+ PKG_CHECK_EXISTS([libdrm_nouveau >= 2.4.33], [NOUVEAU=yes], [NOUVEAU=no])
+fi
if test "x$NOUVEAU" = xyes; then
PKG_CHECK_MODULES(DRM_NOUVEAU, [libdrm_nouveau >= 2.4.33])
AC_DEFINE(HAVE_NOUVEAU, 1, [Have nouveau support])