summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDamien Lespiau <damien.lespiau@intel.com>2013-01-19 23:25:22 +0000
committerDamien Lespiau <damien.lespiau@intel.com>2013-03-04 15:54:37 +0000
commit7902f2c08ce1cbe591f3ce43621d42d42a44bdf9 (patch)
tree21d48b50a90524504210deeb806977cd65ca3bb5 /configure.ac
parent241c5a1322e96871ca1c296266b89b25200d366b (diff)
assembler: Don't use -Wpointer-arith
Mesa's code uses the GNU C extension that allows additions and soustractions on void* (+/- 1). Signed-off-by: Damien Lespiau <damien.lespiau@intel.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index bc8bd391d..1c4e1c652 100644
--- a/configure.ac
+++ b/configure.ac
@@ -64,7 +64,7 @@ XORG_DEFAULT_OPTIONS
# it generates waaaay to many warnings.
ASSEMBLER_WARN_CFLAGS=""
if test "x$GCC" = "xyes"; then
- ASSEMBLER_WARN_CFLAGS="-Wall -Wpointer-arith -Wstrict-prototypes \
+ ASSEMBLER_WARN_CFLAGS="-Wall -Wstrict-prototypes \
-Wmissing-prototypes -Wmissing-declarations \
-Wnested-externs -fno-strict-aliasing"
fi