summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBen Widawsky <ben@bwidawsk.net>2013-02-07 08:29:24 -0800
committerBen Widawsky <ben@bwidawsk.net>2013-02-07 16:42:18 -0800
commit66ec9bd4e7abc7e65edf6518b034ec55b3b7d682 (patch)
tree5348f5bc3ca469725afe58e0d89d61f94da67ad2 /configure.ac
parent3a752a3d9a7aa2c9d8c710c7c889e9cd09384aed (diff)
configure.ac: Move prime stuff to where it belongs
Signed-off-by: Ben Widawsky <ben@bwidawsk.net>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac20
1 files changed, 10 insertions, 10 deletions
diff --git a/configure.ac b/configure.ac
index d66c9f95d..138127964 100644
--- a/configure.ac
+++ b/configure.ac
@@ -59,16 +59,6 @@ XORG_DEFAULT_OPTIONS
PKG_CHECK_MODULES(DRM, [libdrm_intel >= 2.4.38 libdrm])
PKG_CHECK_MODULES(PCIACCESS, [pciaccess >= 0.10])
-# for dma-buf tests
-AC_ARG_ENABLE(nouveau, AS_HELP_STRING([--disable-nouveau],
- [Enable use of nouveau API for prime tests (default: enabled)]),
- [NOUVEAU=$enableval], [NOUVEAU=yes])
-if test "x$NOUVEAU" = xyes; then
- PKG_CHECK_MODULES(DRM_NOUVEAU, [libdrm_nouveau >= 2.4.33])
- AC_DEFINE(HAVE_NOUVEAU, 1, [Have nouveau support])
-fi
-AM_CONDITIONAL(HAVE_NOUVEAU, [test "x$NOUVEAU" = xyes])
-
# for testdisplay
PKG_CHECK_MODULES(CAIRO, cairo)
PKG_CHECK_MODULES(LIBUDEV, [libudev], [udev=yes], [udev=no])
@@ -80,6 +70,16 @@ PKG_CHECK_MODULES(GLIB, glib-2.0)
# -----------------------------------------------------------------------------
# Configuration options
# -----------------------------------------------------------------------------
+# for dma-buf tests
+AC_ARG_ENABLE(nouveau, AS_HELP_STRING([--disable-nouveau],
+ [Enable use of nouveau API for prime tests (default: enabled)]),
+ [NOUVEAU=$enableval], [NOUVEAU=yes])
+if test "x$NOUVEAU" = xyes; then
+ PKG_CHECK_MODULES(DRM_NOUVEAU, [libdrm_nouveau >= 2.4.33])
+ AC_DEFINE(HAVE_NOUVEAU, 1, [Have nouveau support])
+fi
+AM_CONDITIONAL(HAVE_NOUVEAU, [test "x$NOUVEAU" = xyes])
+
# Define a configure option for the shadder debugger
AC_ARG_ENABLE(shader-debugger, AS_HELP_STRING([--enable-shader-debugger],
[Enable shader debugging support [autodetected]]),