summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBen Widawsky <ben@bwidawsk.net>2013-02-07 08:28:14 -0800
committerBen Widawsky <ben@bwidawsk.net>2013-02-07 18:22:00 -0800
commit1cce7eb21b0d78bf8a8848ad1698309f683b9d9d (patch)
tree20c61c761952a98003f4ef9db0e7e0a3f8d029c8 /configure.ac
parent1f2e037e8fabaa30264c1ad8c3dc0e4fc5e13769 (diff)
quick_dump: Give dumper an AM_CONDITIONAL
It may sometimes be undesirable to build or install the quick dumper. This was requested by Damien. Signed-off-by: Damien Lespiau <damien.lespiau@intel.com> Signed-off-by: Ben Widawsky <ben@bwidawsk.net>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac19
1 files changed, 14 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index b8e34d34c..5e2dbed7b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -50,11 +50,6 @@ AC_CHECK_FUNCS([asprintf])
AC_DISABLE_STATIC
AC_PROG_LIBTOOL
-# SWIG configuration
-AX_PKG_SWIG(2.0.0, [], [ AC_MSG_ERROR([SWIG 2.0.0 or higher is required to build..]) ])
-AX_PYTHON_DEVEL([>= '3.0'])
-AX_SWIG_PYTHON
-
# Require X.Org macros 1.16 or later for XORG_TESTSET_CFLAG
m4_ifndef([XORG_MACROS_VERSION],
[m4_fatal([must install xorg-macros 1.16 or later before running autoconf/autogen])])
@@ -85,6 +80,20 @@ if test "x$NOUVEAU" = xyes; then
fi
AM_CONDITIONAL(HAVE_NOUVEAU, [test "x$NOUVEAU" = xyes])
+#Configure options for the python quick-dumper
+AC_ARG_ENABLE(dumper,
+ AS_HELP_STRING([--disable-dumper],
+ [Disable the python based register dumper (default: enabled)]),
+ DUMPER=$enableval], [DUMPER=yes])
+if test "x$DUMPER" == xyes; then
+ AC_DEFINE(HAVE_DUMPER, 1, [Have dumper support])
+ # SWIG configuration
+ AX_PKG_SWIG(2.0.0, [], [ AC_MSG_ERROR([SWIG 2.0.0 or higher is required to build..]) ])
+ AX_PYTHON_DEVEL([>= '3.0'])
+ AX_SWIG_PYTHON
+fi
+AM_CONDITIONAL(HAVE_DUMPER, [test "x$DUMPER" = xyes])
+
# Define a configure option for the shadder debugger
AC_ARG_ENABLE(shader-debugger, AS_HELP_STRING([--enable-shader-debugger],
[Enable shader debugging support [autodetected]]),