summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDamien Lespiau <damien.lespiau@intel.com>2013-01-14 23:21:21 +0000
committerDamien Lespiau <damien.lespiau@intel.com>2013-03-04 15:54:35 +0000
commit191c85976d7f924de781ac4d9ad8a73b034493bf (patch)
tree2465ba4c109bf8ae4f9fc9d6641651d06116800b /configure.ac
parente466360df9ca2d43754e825eb496d8dd23c9ccf0 (diff)
build: Integrate the merged gen assembler in the build system
Signed-off-by: Damien Lespiau <damien.lespiau@intel.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac19
1 files changed, 19 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 5e2dbed7b..832da27e6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -38,7 +38,12 @@ AM_INIT_AUTOMAKE([foreign dist-bzip2])
AM_PATH_PYTHON([3],, [:])
AM_MAINTAINER_MODE
+AC_PROG_CC
+AM_PROG_LEX
+AC_PROG_YACC
+
# Checks for functions, headers, structures, etc.
+AC_HEADER_STDC
AC_CHECK_HEADERS([termios.h])
AC_CHECK_MEMBERS([struct sysinfo.totalram],[],[],[AC_INCLUDES_DEFAULT
#include <sys/sysinfo.h>
@@ -56,6 +61,16 @@ m4_ifndef([XORG_MACROS_VERSION],
XORG_MACROS_VERSION(1.16)
XORG_DEFAULT_OPTIONS
+# warning flags for the assembler. We can't quite use CWARNFLAGS for it yet as
+# it generates waaaay to many warnings.
+ASSEMBLER_WARN_CFLAGS=""
+if test "x$GCC" = "xyes"; then
+ ASSEMBLER_WARN_CFLAGS="-Wall -Wpointer-arith -Wstrict-prototypes \
+ -Wmissing-prototypes -Wmissing-declarations \
+ -Wnested-externs -fno-strict-aliasing"
+fi
+AC_SUBST(ASSEMBLER_WARN_CFLAGS)
+
PKG_CHECK_MODULES(DRM, [libdrm_intel >= 2.4.38 libdrm])
PKG_CHECK_MODULES(PCIACCESS, [pciaccess >= 0.10])
@@ -157,6 +172,10 @@ AC_CONFIG_FILES([
tools/quick_dump/Makefile
debugger/Makefile
debugger/system_routine/Makefile
+ assembler/Makefile
+ assembler/doc/Makefile
+ assembler/test/Makefile
+ assembler/intel-gen4asm.pc
])
AC_OUTPUT