summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDaniel Vetter <daniel.vetter@ffwll.ch>2012-01-19 13:01:03 +0100
committerDaniel Vetter <daniel.vetter@ffwll.ch>2012-01-19 13:07:25 +0100
commit08ccec1ec77a92ec1aa766c8571a0a7a2e6541f8 (patch)
treeafe7c7edd8d0e146833cc6e1e7c7fac44ce63e3a /configure.ac
parentf07e4d1885fbf54a4faa1f91a92fa9499e11b011 (diff)
tests: make testdisplay non-optional
Not testing modesetting should not be an option. Also this hopefully prevents testdisplay build-breakage from lingering on for days like it has in the past. And we want to eventually test the gem/kms cross-section, i.e. pageflips. Acked-by: Chris Wilson <chris@chris-wilson.co.uk> Signed-Off-by: Daniel Vetter <daniel.vetter@ffwll.ch>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac21
1 files changed, 4 insertions, 17 deletions
diff --git a/configure.ac b/configure.ac
index 3af123e49..19744e087 100644
--- a/configure.ac
+++ b/configure.ac
@@ -55,23 +55,10 @@ XORG_DEFAULT_OPTIONS
PKG_CHECK_MODULES(DRM, [libdrm_intel >= 2.4.30 libdrm])
PKG_CHECK_MODULES(PCIACCESS, [pciaccess >= 0.10])
-PKG_CHECK_MODULES(CAIRO, cairo, [HAVE_CAIRO=yes], [HAVE_CAIRO=no])
-if test "x$HAVE_CAIRO" = xyes; then
- AC_DEFINE(HAVE_CAIRO, 1, [Have cairo support])
-fi
-AM_CONDITIONAL(HAVE_CAIRO, [test "x$HAVE_CAIRO" = xyes])
-
-PKG_CHECK_MODULES(LIBUDEV, libudev, [HAVE_LIBUDEV=yes], [HAVE_LIBUDEV=no])
-if test "x$HAVE_LIBUDEV" = xyes; then
- AC_DEFINE(HAVE_LIBUDEV, 1, [Have libudev support])
-fi
-AM_CONDITIONAL(HAVE_LIBUDEV, [test "x$HAVE_LIBUDEV" = xyes])
-
-PKG_CHECK_MODULES(GLIB, glib-2.0, [HAVE_GLIB=yes], [HAVE_GLIB=no])
-if test "x$HAVE_GLIB" = xyes; then
- AC_DEFINE(HAVE_GLIB, 1, [Have glib support])
-fi
-AM_CONDITIONAL(HAVE_GLIB, [test "x$HAVE_GLIB" = xyes])
+# for testdisplay
+PKG_CHECK_MODULES(CAIRO, cairo)
+PKG_CHECK_MODULES(LIBUDEV, libudev)
+PKG_CHECK_MODULES(GLIB, glib-2.0)
# -----------------------------------------------------------------------------
# Configuration options