summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am19
1 files changed, 18 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index e1450cdd..dc120d35 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,4 +1,21 @@
-SUBDIRS=dbus bus test doc
+if HAVE_GLIB
+ GLIB_SUBDIR=glib
+ GLIB_PC=dbus-glib-1.0.pc
+endif
+
+SUBDIRS=dbus $(GLIB_SUBDIR) bus test doc
+
+pkgconfigdir = $(libdir)/pkgconfig
+pkgconfig_DATA = dbus-1.0.pc $(GLIB_PC)
+
+DISTCLEANFILES = \
+ dbus-1.0.pc \
+ $(GLIB_PC)
+
+EXTRA_DIST = \
+ dbus-1.0.pc.in \
+ dbus-glib-1.0.pc.in
all-local: Doxyfile
+