summaryrefslogtreecommitdiff
path: root/glib/Makefile.am
diff options
context:
space:
mode:
authorAlexander Larsson <alexl@redhat.com>2003-02-27 14:22:36 +0000
committerAlexander Larsson <alexl@redhat.com>2003-02-27 14:22:36 +0000
commit83087f783bb067e0809a6648a8bdb14e8e49efbf (patch)
tree102af3c8bdff369d6dc6637d68c668d933dbab0d /glib/Makefile.am
parentff190005e5e518c1d78fd83b0da3642280ead84c (diff)
2003-02-27 Alexander Larsson <alexl@redhat.com>
* glib/Makefile.am: * configure.in: Make gthreads-2.0 dependency optional. Don't build thread test if its not found.
Diffstat (limited to 'glib/Makefile.am')
-rw-r--r--glib/Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/glib/Makefile.am b/glib/Makefile.am
index 63d2edb9..d9edf6f5 100644
--- a/glib/Makefile.am
+++ b/glib/Makefile.am
@@ -16,13 +16,18 @@ libdbus_glib_1_la_LIBADD= $(DBUS_GLIB_LIBS) $(top_builddir)/dbus/libdbus-1.la
if DBUS_BUILD_TESTS
-noinst_PROGRAMS= test-dbus-glib test-thread-server test-thread-client
+if HAVE_GLIB_THREADS
+ THREAD_APPS=test-thread-server test-thread-client
+endif
+
+noinst_PROGRAMS= test-dbus-glib $(THREAD_APPS)
test_dbus_glib_SOURCES= \
test-dbus-glib.c
test_dbus_glib_LDADD= $(top_builddir)/glib/libdbus-glib-1.la
+if HAVE_GLIB_THREADS
test_thread_server_SOURCES= \
test-thread-server.c \
test-thread.h
@@ -34,5 +39,6 @@ test_thread_client_SOURCES= \
test-thread.h
test_thread_client_LDADD= $(DBUS_GLIB_THREADS_LIBS) $(top_builddir)/glib/libdbus-glib-1.la
+endif
endif