summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorHavoc Pennington <hp@redhat.com>2003-04-03 21:56:22 +0000
committerHavoc Pennington <hp@redhat.com>2003-04-03 21:56:22 +0000
commitf216e81432ddf04889202c33a6e68113f94d7611 (patch)
treebb8386366d183e43dc3471219ec627a21c65a639 /configure.in
parentfe9f3b45cc7e2e84d180c433f1ab5f8fd0a0c619 (diff)
2003-04-03 Havoc Pennington <hp@redhat.com>
* bus/activation.c (load_directory): fix up memleaks (bus_activation_entry_free): free the entry * dbus/dbus-bus.c (dbus_bus_acquire_service): return an error if we get one from the message bus; fix memleaks. * dbus/dbus-message.c (dbus_set_error_from_message): new function
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index fbf60d78..076b74c3 100644
--- a/configure.in
+++ b/configure.in
@@ -403,6 +403,15 @@ fi
AM_CONDITIONAL(DBUS_INIT_SCRIPTS_RED_HAT, test x$with_init_scripts = xredhat)
+#### Tell tests where to find certain stuff in builddir
+ABSOLUTE_TOP_BUILDDIR=`cd ${ac_top_builddir}. && pwd`
+
+TEST_SERVICE_BINARY=${ABSOLUTE_TOP_BUILDDIR}/test/test-service
+AC_SUBST(TEST_SERVICE_BINARY)
+
+TEST_SERVICE_DIR=${ABSOLUTE_TOP_BUILDDIR}/test/data/valid-service-files
+AC_SUBST(TEST_SERVICE_DIR)
+
AC_OUTPUT([
Doxyfile
bus/system.conf
@@ -417,6 +426,8 @@ test/Makefile
doc/Makefile
dbus-1.0.pc
dbus-glib-1.0.pc
+test/data/valid-config-files/debug-allow-all.conf
+test/data/valid-service-files/debug-echo.service
])
dnl ==========================================================================