summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSimon McVittie <simon.mcvittie@collabora.co.uk>2012-07-03 15:53:31 +0100
committerSimon McVittie <simon.mcvittie@collabora.co.uk>2012-07-03 19:03:19 +0100
commitd8de80969c090c70e0bfe1d5e68fc7f783fd18e4 (patch)
treeac2602ceb25efc9ac91bfcd3a97c398aa5654600 /configure.ac
parente5a945507b045eb46c43da5c0f29a6ee9ab5dbee (diff)
Set enable-developer default to 'no'
Misplaced [] and () led to enable_developer=no being part of the option's documentation instead of actually being the default value. Regression in 1.6.2, caused by #34671. Bug: https://bugs.freedesktop.org/show_bug.cgi?id=51657 Bug-Debian: http://bugs.debian.org/680027 Reviewed-by: David Zeuthen <davidz@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 3 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index f1b40a0c..698fcd15 100644
--- a/configure.ac
+++ b/configure.ac
@@ -127,8 +127,9 @@ AM_CONDITIONAL(DBUS_CYGWIN, test "$dbus_cygwin" = yes)
# this must come first: other options use this to set their defaults
AC_ARG_ENABLE([developer],
[AS_HELP_STRING([--enable-developer],
- [set defaults to be appropriate for a D-Bus developer instead of a distribution/end-user]),
- [], enable_developer=no])
+ [set defaults to be appropriate for a D-Bus developer instead of a distribution/end-user])],
+ [],
+ [enable_developer=no])
DBUS_STATIC_BUILD_CPPFLAGS=
if test "x$enable_shared" = xno; then