summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSimon McVittie <simon.mcvittie@collabora.co.uk>2011-03-01 15:14:02 +0000
committerSimon McVittie <simon.mcvittie@collabora.co.uk>2011-06-24 16:00:43 +0100
commitbc212b72b29caea8d73b4c9a5d3884257c700250 (patch)
tree454682dc67b5723288131876b6f69027334546ab /configure.ac
parent85e9a283035b935c147408f88fb8dd8fcc225edf (diff)
configure.ac: add --enable-stats
Reviewed-by: Cosimo Alfarano <cosimo.alfarano@collabora.co.uk> Bug: https://bugs.freedesktop.org/show_bug.cgi?id=34040
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index a6817578..a98b729e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1558,6 +1558,15 @@ AH_VERBATIM(_DARWIN_ENVIRON,
#endif
])
+AC_ARG_ENABLE([stats],
+ [AS_HELP_STRING([--enable-stats],
+ [enable bus daemon usage statistics])],
+ [], [enable_stats=no])
+if test "x$enable_stats" = xyes; then
+ AC_DEFINE([DBUS_ENABLE_STATS], [1],
+ [Define to enable bus daemon usage statistics])
+fi
+
AC_CONFIG_FILES([
Doxyfile
dbus/versioninfo.rc
@@ -1633,6 +1642,7 @@ echo "
Building verbose mode: ${enable_verbose_mode}
Building assertions: ${enable_asserts}
Building checks: ${enable_checks}
+ Building bus stats API: ${enable_stats}
Building SELinux support: ${have_selinux}
Building inotify support: ${have_inotify}
Building dnotify support: ${have_dnotify}