summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSimon McVittie <simon.mcvittie@collabora.co.uk>2011-01-26 18:24:03 +0000
committerSimon McVittie <simon.mcvittie@collabora.co.uk>2011-07-18 19:14:47 +0100
commit41d7854cea6b192b3f406aaf37d969cbd9dcb153 (patch)
tree4d22d3750d456dd4638caa5a3c890c79078000fd /configure.ac
parentaf13ae7e43c444e1ff08d477b454bdee8cd9f892 (diff)
Opt-in to modern OS features on Solaris, to get file descriptor passing
Surely it's broken to define SCM_RIGHTS but not the necessary structs to do something useful with it, but whatever. Bug: https://bugs.freedesktop.org/show_bug.cgi?id=33465 Reviewed-by: Will Thompson <will.thompson@collabora.co.uk>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index a7680703..a4c21855 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1231,6 +1231,9 @@ case $host_os in
solaris*)
# Solaris' C library apparently needs these runes to be threadsafe...
CFLAGS="$CFLAGS -D_POSIX_PTHREAD_SEMANTICS -D_REENTRANT"
+ # ... and this opt-in to get file descriptor passing support
+ CFLAGS="$CFLAGS -D_XOPEN_SOURCE=500"
+ ;;
esac
### Doxygen Documentation