summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSimon McVittie <simon.mcvittie@collabora.co.uk>2011-02-24 15:46:34 +0000
committerSimon McVittie <simon.mcvittie@collabora.co.uk>2011-02-24 15:46:34 +0000
commitdac0a716ad969ef3a4d179f50697d8cb0e7b15ac (patch)
treecafd73ea4dd4ff3ff4313d973c228d02c4364994 /configure.ac
parent5906c072da69c084a3286e152aa64c0448e71865 (diff)
Modernize checks for cmsgcred
Part of a patch by Javier Jardón. Bug: https://bugs.freedesktop.org/show_bug.cgi?id=32245 Reviewed-by: Simon McVittie <simon.mcvittie@collabora.co.uk>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 5 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 86e486ab..8440c2ce 100644
--- a/configure.ac
+++ b/configure.ac
@@ -658,14 +658,16 @@ fi
dnl Check for various credentials.
AC_MSG_CHECKING(for struct cmsgcred)
-AC_TRY_COMPILE([
+AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
#include <sys/types.h>
#include <sys/socket.h>
-],[
+]], [[
struct cmsgcred cred;
cred.cmcred_pid = 0;
-],dbus_have_struct_cmsgcred=yes,dbus_have_struct_cmsgcred=no)
+]])],
+[dbus_have_struct_cmsgcred=yes],
+[dbus_have_struct_cmsgcred=no])
AC_MSG_RESULT($dbus_have_struct_cmsgcred)
if test x$dbus_have_struct_cmsgcred = xyes; then