summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSimon McVittie <simon.mcvittie@collabora.co.uk>2011-02-25 12:02:00 +0000
committerSimon McVittie <simon.mcvittie@collabora.co.uk>2011-02-25 12:02:02 +0000
commitc35e12fda9f004b51716ea446dfe9370f7aac299 (patch)
tree133c75d1cc9a0d678e18f3c414db98dba7cae80d /configure.ac
parentbe5e2b23c93b3d93d8d02f3870618c29f3737239 (diff)
parent5cad0830698541bcea2fd6b200038ae96fde051d (diff)
Merge branch 'changequote' into dbus-1.4
Reviewed-by: Will Thompson <will.thompson@collabora.co.uk>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 5 insertions, 11 deletions
diff --git a/configure.ac b/configure.ac
index 3a5bc45d..815783dc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1156,8 +1156,10 @@ if test x$dbus_win != xyes -a x$dbus_cygwin != xyes -a x$USE_MAINTAINER_MODE = x
fi
fi
-if test "x$GCC" = "xyes"; then
- changequote(,)dnl
+dnl This whole "if" block is in m4 quotes ([]) because it uses them
+dnl for character ranges internally. m4 macros cannot be used inside this
+dnl block.
+[if test "x$GCC" = "xyes"; then
case " $CFLAGS " in
*[\ \ ]-Wall[\ \ ]*) ;;
*) CFLAGS="$CFLAGS -Wall" ;;
@@ -1299,8 +1301,7 @@ if test "x$GCC" = "xyes"; then
*) CFLAGS="$CFLAGS -pedantic" ;;
esac
fi
- changequote([,])dnl
-fi
+fi]
AC_SUBST(PIC_CFLAGS)
AC_SUBST(PIC_LDFLAGS)
@@ -1321,13 +1322,6 @@ case $host_os in
CFLAGS="$CFLAGS -D_POSIX_PTHREAD_SEMANTICS -D_REENTRANT"
esac
-changequote(,)dnl
-# compress spaces in flags
-CFLAGS=`echo "$CFLAGS" | sed -e 's/ +/ /g'`
-CXXFLAGS=`echo "$CXXFLAGS" | sed -e 's/ +/ /g'`
-CPPFLAGS=`echo "$CPPFLAGS" | sed -e 's/ +/ /g'`
-changequote([,])dnl
-
### Doxygen Documentation
AC_PATH_PROG(DOXYGEN, doxygen, no)