summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorHavoc Pennington <hp@redhat.com>2003-06-22 05:53:06 +0000
committerHavoc Pennington <hp@redhat.com>2003-06-22 05:53:06 +0000
commit93b5a19c9f0979b5f227760af2ce5a0d076521f9 (patch)
tree1704ae1cbebdfacc0ca5d7c98e9c90bf55b27fd3 /Makefile.am
parent8e99e853a7abbb5344240c35b66853eeaedca48e (diff)
2003-06-22 Havoc Pennington <hp@pobox.com>
* mono/*, gcj/*, configure.in, Makefile.am: Check in makefiles and subdirs for mono and gcj bindings. Neither binding actually exists, just trying to get through all the build and other boring bits.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 10 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 4b733db9..7384af0d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -8,7 +8,16 @@ if HAVE_QT
QT_SUBDIR=qt
endif
-SUBDIRS=dbus bus test doc $(GLIB_SUBDIR) $(QT_SUBDIR) tools
+if DBUS_USE_GCJ
+ GCJ_SUBDIR=gcj
+endif
+
+if DBUS_USE_MCS
+ MONO_SUBDIR=mono
+endif
+
+
+SUBDIRS=dbus bus test doc $(GLIB_SUBDIR) $(GCJ_SUBDIR) $(MONO_SUBDIR) $(QT_SUBDIR) tools
pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = dbus-1.pc $(GLIB_PC)