summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorHavoc Pennington <hp@redhat.com>2003-10-17 16:23:19 +0000
committerHavoc Pennington <hp@redhat.com>2003-10-17 16:23:19 +0000
commit8a4d94fe70982690c5fe4580f906b8ca2a95c468 (patch)
treefc60bbc6175622bce838bfb83209c6f692181b18 /Makefile.am
parentc20c4181f275f24413eeff2ea85d2a0d539c9a91 (diff)
2003-10-16 Havoc Pennington <hp@redhat.com>
* glib/dbus-gtest-main.c: bracket with #ifdef DBUS_BUILD_TESTS * Makefile.am (GCOV_DIRS): remove "test", we don't care about test coverage of the tests (coverage-report.txt): don't move the .da and .bbg files around
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am42
1 files changed, 15 insertions, 27 deletions
diff --git a/Makefile.am b/Makefile.am
index fce48628..82fee346 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -50,37 +50,25 @@ clean-gcov:
clean-bbg:
find -name "*.bbg" -o -name "*.bb" | xargs rm || true
-GCOV_DIRS=dbus bus test $(GLIB_SUBDIR) $(QT_SUBDIR)
+GCOV_DIRS=dbus bus $(GLIB_SUBDIR) $(QT_SUBDIR)
## .PHONY so it always rebuilds it
.PHONY: coverage-report.txt
coverage-report.txt:
- BBG_FILES=`find $(GCOV_DIRS) -name "*.bbg"` ; \
- for F in $$BBG_FILES ; do \
- F_nolibs=`echo $$F | sed -e 's/.libs\///g'` ; \
- if test $$F != $$F_nolibs ; then \
- echo "Moving $$F to $$F_nolibs" ; \
- mv -f $$F $$F_nolibs ; \
- fi ; \
- done ; \
- DA_FILES=`find $(GCOV_DIRS) -name "*.da"` ; \
- for F in $$DA_FILES ; do \
- F_nolibs=`echo $$F | sed -e 's/.libs\///g'` ; \
- if test $$F != $$F_nolibs ; then \
- echo "Moving $$F to $$F_nolibs" ; \
- mv -f $$F $$F_nolibs ; \
- fi ; \
- done ; \
- BBG_FILES=`find $(GCOV_DIRS) -name "*.bbg"` ; \
- C_FILES= ; \
- for F in $$BBG_FILES ; do \
- C=`echo $$F | sed -e 's/.bbg/.c/g'` ; \
- DA=`echo $$F | sed -e 's/.bbg/.da/g'` ; \
- if test -e $$DA ; then \
- C_FILES="$$C_FILES $$C" ; \
- fi ; \
- done ; \
- echo $$C_FILES ; \
+ BBG_FILES=`find $(GCOV_DIRS) -name "*.bbg"` ; \
+ C_FILES= ; \
+ for F in $$BBG_FILES ; do \
+ F_nolibs=`echo $$F | sed -e 's/.libs\///g'` ; \
+ C=`echo $$F_nolibs | sed -e 's/.bbg/.c/g'` ; \
+ B=`basename $$F .bbg` ; \
+ D=`dirname $$F` ; \
+ DA=`echo $$F | sed -e 's/.bbg/.da/g'` ; \
+ DA_libs=`echo $$D/.libs/$$B/.da` ; \
+ if test -e $$DA || test -e $$DA_libs; then \
+ C_FILES="$$C_FILES $$C" ; \
+ fi ; \
+ done ; \
+ echo $$C_FILES ; \
$(top_builddir)/test/decode-gcov --report $$C_FILES > coverage-report.txt
check-coverage: clean-gcov all check coverage-report.txt