summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorHavoc Pennington <hp@redhat.com>2003-04-30 21:15:44 +0000
committerHavoc Pennington <hp@redhat.com>2003-04-30 21:15:44 +0000
commit42d47c5f805b61892456b17a0e5b2632d73745bd (patch)
tree3549facdff6fe32eda39c910ae1239490ef487c6 /Makefile.am
parent410a80c43126376e9308a03a7cef108716018f5a (diff)
2003-04-30 Havoc Pennington <hp@redhat.com>
* Makefile.am: add a check-local that complains if you didn't configure with --enable-tests
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 2bf9a509..91c976e8 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -24,6 +24,14 @@ EXTRA_DIST = \
all-local: Doxyfile
+if DBUS_BUILD_TESTS
+### nothing
+else
+check-local:
+ echo "You have to configure with --enable-tests to make check" ; \
+ exit 1
+endif
+
if DBUS_GCOV_ENABLED
clean-gcov:
find -name "*.da" -o -name "*.gcov" | xargs rm || true