summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorHarri Porten <porten@kde.org>2002-12-28 09:10:43 +0000
committerHarri Porten <porten@kde.org>2002-12-28 09:10:43 +0000
commitb7354d91569384ba884bd3e391210019037ada2c (patch)
tree7ecb6a83c969afc11b740f687bdd11bda1d14aac /Makefile.am
parentebd603e725695b58215d2928292c9f1cadd6f3e4 (diff)
very basic check for Qt integration. Another proof that Qt's build
system needs more work for people using it. I didn't want to copy all of KDEs autoconf magic so this is far from perfect, yet. Can we use pkg-config here ?
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index dc120d35..a197cf39 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -4,7 +4,11 @@ if HAVE_GLIB
GLIB_PC=dbus-glib-1.0.pc
endif
-SUBDIRS=dbus $(GLIB_SUBDIR) bus test doc
+if HAVE_QT
+ QT_SUBDIR=qt
+endif
+
+SUBDIRS=dbus $(GLIB_SUBDIR) $(QT_SUBDIR) bus test doc
pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = dbus-1.0.pc $(GLIB_PC)