summaryrefslogtreecommitdiff
path: root/test/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am35
1 files changed, 27 insertions, 8 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index e7fd3fd6b..04d42e2d6 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -3,18 +3,27 @@ TESTS = \
fill_rule \
leaky_polygon \
line_width \
+linear_gradient \
move_to_show_surface \
text_cache_crash \
-text_rotate
+text_rotate \
+coverage \
+clip_twice \
+pixman_rotate
-# And all new test go here too. I really don't like having to repeat
+# And all new tests go here too. I really don't like having to repeat
# this list. Anyone know a good way to avoid it? Can I use a wildcard
# here?
-EXTRA_DIST = \
-fill_rule-ref.png \
-leaky_polygon-ref.png \
-line_width-ref.png \
-move_to_show_surface-ref.png
+EXTRA_DIST = \
+fill_rule-ref.png \
+leaky_polygon-ref.png \
+line_width-ref.png \
+linear_gradient-ref.png \
+move_to_show_surface-ref.png \
+coverage-ref.png \
+clip_twice-ref.png \
+pixman_rotate-ref.png \
+romedalen.png
# Once we can draw the text_rotate.c test case correctly, we should
# create and add text_rotate-ref.png to the list of reference PNGs.
@@ -29,6 +38,7 @@ move_to_show_surface-ref.png
# be fixed before the code is committed.
XFAIL_TESTS = \
move_to_show_surface \
+pixman_rotate \
text_rotate
check_PROGRAMS = $(TESTS)
@@ -42,6 +52,8 @@ INCLUDES = -D_GNU_SOURCE -I$(srcdir) $(CAIRO_CFLAGS) -I$(srcdir)/../src
AM_LDFLAGS = $(CAIRO_LIBS) ../src/libcairo.la
cairo_test_lib =\
+buffer_diff.c \
+buffer_diff.h \
cairo_test.c \
cairo_test.h \
read_png.c \
@@ -57,8 +69,15 @@ xmalloc.h
fill_rule_SOURCES = fill_rule.c $(cairo_test_lib)
leaky_polygon_SOURCES = leaky_polygon.c $(cairo_test_lib)
line_width_SOURCES = line_width.c $(cairo_test_lib)
+linear_gradient_SOURCES = linear_gradient.c $(cairo_test_lib)
move_to_show_surface_SOURCES = move_to_show_surface.c $(cairo_test_lib)
text_cache_crash_SOURCES = text_cache_crash.c $(cairo_test_lib)
text_rotate_SOURCES = text_rotate.c $(cairo_test_lib)
+coverage_SOURCES = coverage.c $(cairo_test_lib)
+clip_twice_SOURCES = clip_twice.c $(cairo_test_lib)
+pixman_rotate_SOURCES = pixman_rotate.c $(cairo_test_lib)
+
+noinst_PROGRAMS = imagediff
+imagediff_SOURCES = imagediff.c $(cairo_test_lib)
-CLEANFILES = *-out.png *-diff.png
+CLEANFILES = *-out.png *-diff.png *.log