summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index e5582a426..325af1091 100644
--- a/configure.ac
+++ b/configure.ac
@@ -502,7 +502,7 @@ have_real_pthread=no
real_pthread_REQUIRES="pthread"
PKG_CHECK_MODULES(real_pthread, $real_pthread_REQUIRES,
[have_real_pthread=yes],
- [AC_CHECK_HEADERS([pthread.h],, [have_real_pthread="no (requires $real_pthread_REQUIRES)"])])
+ [AC_CHECK_HEADERS([pthread.h],[real_pthread_LIBS="-lpthread"], [have_real_pthread="no (requires $real_pthread_REQUIRES)"])])
AM_CONDITIONAL(HAVE_REAL_PTHREAD, test "x$have_real_pthread" = "xyes")
dnl ===========================================================================