summaryrefslogtreecommitdiff
path: root/pixman/Makefile.am
diff options
context:
space:
mode:
authorCarl Worth <cworth@cworth.org>2004-10-28 08:48:07 +0000
committerCarl Worth <cworth@cworth.org>2004-10-28 08:48:07 +0000
commit0340265ce470e12ed434cbcde56f44a01e06c046 (patch)
tree4c37071cf6e2faf66e6a2e27d62a3a43b7349a10 /pixman/Makefile.am
parent2473e782ca5e92cb70837daf4d2950253170fe66 (diff)
Abort release-publish if there's already a published tar file with the current version. (release-publish): Add code to update the LATEST-package-version file.
Diffstat (limited to 'pixman/Makefile.am')
-rw-r--r--pixman/Makefile.am25
1 files changed, 16 insertions, 9 deletions
diff --git a/pixman/Makefile.am b/pixman/Makefile.am
index eea99b0a6..63f66d2da 100644
--- a/pixman/Makefile.am
+++ b/pixman/Makefile.am
@@ -10,18 +10,19 @@ EXTRA_DIST = \
pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = libpixman.pc
-tar_file = $(PACKAGE)-$(VERSION).tar.gz
-md5_file = $(tar_file).md5
-
# Some custom targets to make it easier to release things.
# Use either:
# make release-check
# or make release-publish
-RELEASE_UPLOAD_DIR = cairographics.org:/home/www/cairo/snapshots
+RELEASE_UPLOAD_HOST = cairographics.org
+RELEASE_UPLOAD_DIR = /home/www/cairo/snapshots
RELEASE_URL_BASE = http://cairographics.org/snapshots
RELEASE_ANNOUNCE_LIST = cairo-announce@cairographics.org
+tar_file = $(PACKAGE)-$(VERSION).tar.gz
+md5_file = $(tar_file).md5
+
$(md5_file): $(tar_file)
md5sum $^ > $@
@@ -30,10 +31,19 @@ release-remove-old:
release-check: release-remove-old distcheck $(md5_file)
-release-publish: release-check
+release-verify-newer:
+ @echo -n "Checking that no $(VERSION) release already exists..."
+ @ssh $(RELEASE_UPLOAD_HOST) test ! -e $(RELEASE_UPLOAD_DIR)/$(tar_file) \
+ || (echo "Ouch." && echo "Found: $(RELEASE_UPLOAD_HOST):$(RELEASE_UPLOAD_DIR)/$(tar_file)" \
+ && echo "The version in configure.in must be incremented before a new release." \
+ && false)
+ @echo "Good."
+
+release-publish: release-verify-newer release-check
mkdir -p releases
- scp $(tar_file) $(md5_file) $(RELEASE_UPLOAD_DIR)
+ scp $(tar_file) $(md5_file) $(RELEASE_UPLOAD_HOST):$(RELEASE_UPLOAD_DIR)
mv $(tar_file) $(md5_file) releases
+ ssh $(RELEASE_UPLOAD_HOST) "rm -f $(RELEASE_UPLOAD_DIR)/LATEST-$(PACKAGE)-[0-9]* && touch $(RELEASE_UPLOAD_DIR)/LATEST-$(PACKAGE)-$(VERSION)"
@echo ""
@echo "Please send an announcement to $(RELEASE_ANNOUNCE_LIST)"
@echo "including the following:"
@@ -48,6 +58,3 @@ release-publish: release-check
@cat releases/$(md5_file)
@echo ""
@echo "Also, please include the new entries from the NEWS file."
-
-
-