summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorBehdad Esfahbod <behdad@behdad.org>2006-06-30 01:44:55 +0200
committerBehdad Esfahbod <behdad@behdad.org>2006-06-30 02:21:51 +0200
commite5d18d7696eb9a48369b89517738dbaa101106d7 (patch)
tree75c22a49940eb5dd04d049db9154ccf76dd9f5e6 /configure.in
parent6c3deb0be1b9d6db0104af02fb193849a8329133 (diff)
Use $no_x in configure.in.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 5 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 835ee7946..cb349566c 100644
--- a/configure.in
+++ b/configure.in
@@ -188,15 +188,18 @@ dnl ===========================================================================
CAIRO_BACKEND_ENABLE(xlib, Xlib, xlib, XLIB_SURFACE, auto, [
AC_PATH_XTRA
- if test "x$X_CFLAGS$X_PRE_LIBS$X_LIBS$X_EXTRA_LIBS" = x; then
+ if test "x$no_x" = xyes; then
use_xlib="no (requires Xlib)"
else
xlib_LIBS="$X_PRE_LIBS $X_LIBS -lX11 $X_EXTRA_LIBS"
xlib_CFLAGS=$X_CFLAGS
- _CHECK_FUNCS_WITH_FLAGS(XrmFinalize, $xlib_CFLAGS, $xlib_LIBS)
fi
])
+if test "x$use_xlib" = xyes; then
+ _CHECK_FUNCS_WITH_FLAGS(XrmFinalize, $xlib_CFLAGS, $xlib_LIBS)
+fi
+
CAIRO_BACKEND_ENABLE(xlib_xrender, Xlib Xrender, xlib-xrender, XLIB_XRENDER_SURFACE, auto, [
use_xlib_xrender=$use_xlib
if test "x$use_xlib_xrender" = xyes; then