summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorBehdad Esfahbod <behdad@behdad.org>2006-07-11 09:23:18 -0400
committerBehdad Esfahbod <behdad@behdad.org>2006-07-11 09:23:18 -0400
commitd27a00874bc044b4c9aefacbc850d5f7ee106b6f (patch)
tree73ba0bc17ab0bbb1210c0c786f9f607101f575b7 /configure.in
parente0ad1aa995bcec4246c0b8ab0d5a5a79871ce235 (diff)
Disable PDF backend if zlib not found.
Explicitly add -lm to CAIRO_LIBS
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in12
1 files changed, 9 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index 0fa411a24..b249d8e4b 100644
--- a/configure.in
+++ b/configure.in
@@ -182,7 +182,7 @@ AC_DEFUN([CAIRO_BACKEND_ENABLE],
CAIRO_FEATURES=""
CAIRO_REQUIRES=""
CAIRO_CFLAGS=""
-CAIRO_LIBS=""
+CAIRO_LIBS="-lm"
dnl ===========================================================================
@@ -442,7 +442,7 @@ CAIRO_BACKEND_ENABLE(ps, PostScript, ps, PS_SURFACE, auto, [], [
if test x"$have_ft_load_sfnt_table" != "xyes" ; then
use_ps="no (requires FreeType 2.1.4 or newer)"
else
- # The postscript module requires zlib.
+ # The postscript backend requires zlib.
AC_CHECK_LIB(z, compress,
[AC_CHECK_HEADER(zlib.h, [],
[use_ps="no (requires zlib http://www.gzip.org/zlib/)"])],
@@ -456,8 +456,14 @@ dnl ===========================================================================
CAIRO_BACKEND_ENABLE(pdf, PDF, pdf, PDF_SURFACE, auto, [], [
if test x"$have_ft_load_sfnt_table" != "xyes" ; then
use_pdf="no (requires FreeType 2.1.4 or newer)"
+ else
+ # The pdf backend requires zlib.
+ AC_CHECK_LIB(z, compress,
+ [AC_CHECK_HEADER(zlib.h, [],
+ [use_ps="no (requires zlib http://www.gzip.org/zlib/)"])],
+ [use_ps="no (requires zlib http://www.gzip.org/zlib/)"])
+ pdf_LIBS=-lz
fi
- pdf_LIBS=-lz
])
test_pdf=no