summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorKristian Høgsberg <krh@redhat.com>2006-06-14 15:00:33 -0400
committerKristian Høgsberg <krh@redhat.com>2006-06-14 15:00:33 -0400
commit2cea3a2710cd4c6eb68e25eadaaf96cdc921ef14 (patch)
tree0259438aeebe5a85dc4f768902ec3b27c7e7655b /configure.in
parent17ea7552355d9925fb99cd4ca98cf38946f99421 (diff)
parent4932d09a06228a08d1c8f4d2892378c004ff3313 (diff)
Merge branch 'svg-rewrite'
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in14
1 files changed, 0 insertions, 14 deletions
diff --git a/configure.in b/configure.in
index fcb72b921..cbe6a7f0d 100644
--- a/configure.in
+++ b/configure.in
@@ -545,17 +545,6 @@ CAIRO_BACKEND_ENABLE(svg, SVG, auto, svg, [], [
fi
])
-if test "x$use_svg" = "xyes" ; then
- use_svg="no (SVG backend requires libxml2)"
- if $PKG_CONFIG --exists libxml-2.0 ; then
- # Sets XML_CFLAGS, XML_LIBS
- PKG_CHECK_MODULES(XML, libxml-2.0)
- use_svg=yes
- else
- AC_MSG_WARN([SVG requires libxml2, which is not found in pkg-config search path, disabling])
- fi
-fi
-
AM_CONDITIONAL(CAIRO_HAS_SVG_SURFACE, test "x$use_svg" = "xyes")
if test "x$use_svg" = "xyes"; then
SVG_SURFACE_FEATURE="#define CAIRO_HAS_SVG_SURFACE 1"
@@ -572,9 +561,6 @@ AM_CONDITIONAL(CAIRO_CAN_TEST_SVG_SURFACE, test "x$test_svg" = "xyes")
AC_SUBST(LIBRSVG_CFLAGS)
AC_SUBST(LIBRSVG_LIBS)
-CAIRO_CFLAGS="$CAIRO_CFLAGS $XML_CFLAGS"
-CAIRO_LIBS="$CAIRO_LIBS $XML_LIBS"
-
dnl ===========================================================================
dnl This check should default to 'yes' once we have code to actually