summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorCarl Worth <cworth@cworth.org>2006-08-31 08:35:39 -0700
committerBehdad Esfahbod <behdad@behdad.org>2006-10-31 20:52:40 -0500
commit1ae5dc7e78bbd926378d9d47714f885b60d7ca63 (patch)
treebb2fa20bbce80189ab791be34a5f32c31b8209e4 /configure.in
parentc55f71bdab977010cab1366f2ee2258999d8b7d5 (diff)
Require librsvg >= 2.14.0 to test SVG backend
(cherry picked from 8d834c3a34a17de0e03841501ea107dee7b373d0 commit)
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in12
1 files changed, 7 insertions, 5 deletions
diff --git a/configure.in b/configure.in
index 94328ae78..a5ec54bce 100644
--- a/configure.in
+++ b/configure.in
@@ -485,13 +485,14 @@ CAIRO_BACKEND_ENABLE(pdf, PDF, pdf, PDF_SURFACE, auto, [
pdf_NONPKGCONFIG_LIBS=-lz
])
+POPPLER_VERSION_REQUIRED=0.4.1
test_pdf=no
if test "x$use_pdf" = "xyes"; then
- PKG_CHECK_MODULES(POPPLER, poppler-glib >= 0.4.1 pango gtk+-2.0, [test_pdf=yes], [test_pdf=no])
+ PKG_CHECK_MODULES(POPPLER, poppler-glib >= $POPPLER_VERSION_REQUIRED pango gtk+-2.0, [test_pdf=yes], [test_pdf=no])
if test "x$test_pdf" = "xyes"; then
AC_DEFINE([CAIRO_CAN_TEST_PDF_SURFACE], 1, [Define to 1 if the PDF backend can be tested (need poppler and other dependencies for pdf2png)])
else
- AC_MSG_WARN([PDF backend will not be tested since poppler is not available])
+ AC_MSG_WARN([PDF backend will not be tested since poppler >= $POPPLER_VERSION_REQUIRED is not available])
fi
fi
@@ -509,12 +510,13 @@ CAIRO_BACKEND_ENABLE(svg, SVG, svg, SVG_SURFACE, auto, [
fi
])
+LIBRSVG_VERSION_REQUIRED=2.14.0
if test "x$use_svg" = "xyes"; then
- PKG_CHECK_MODULES(LIBRSVG, librsvg-2.0 gdk-2.0, [test_svg=yes], [test_svg=no])
+ PKG_CHECK_MODULES(LIBRSVG, librsvg-2.0 >= $LIBRSVG_VERSION_REQUIRED gdk-2.0, [test_svg=yes], [test_svg=no])
if test "x$test_svg" = "xyes"; then
- AC_DEFINE([CAIRO_CAN_TEST_SVG_SURFACE], 1, [Define to 1 if the SVG backend can be tested (need librsvg)])
+ AC_DEFINE([CAIRO_CAN_TEST_SVG_SURFACE], 1, [Define to 1 if the SVG backend can be tested])
else
- AC_MSG_WARN([SVG backend will not be tested since a librsvg is not available])
+ AC_MSG_WARN([SVG backend will not be tested since librsvg >= $LIBRSVG_VERSION_REQUIRED is not available])
fi
fi