summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChris Wilson <chris@chris-wilson.co.uk>2009-05-19 15:53:55 +0100
committerChris Wilson <chris@chris-wilson.co.uk>2009-05-20 08:13:45 +0100
commit87b764908a38cbb4159ac76d8b7d1d08a24b838e (patch)
tree90150c81390f7e8386474b43f28fbb8a939f3725 /configure.ac
parent17b41fe7e3b8b493341be6384d816105aadf0cb6 (diff)
[gl] Add EGL target
Split the GLX context from the GL surface to enable use of an alternative EGL interface.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac30
1 files changed, 28 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 4d1e81164..821545ff6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -199,14 +199,40 @@ CAIRO_ENABLE_SURFACE_BACKEND(gl, gl, no, [
AC_CHECK_LIB(GLEW, glewInit, [
AC_CHECK_HEADER(GL/glew.h, [], [
- have_gl="no (requires glew http://glew.sourceforge.net/)"
+ use_gl="no (requires glew http://glew.sourceforge.net/)"
])
], [
- have_gl="no (requires glew http://glew.sourceforge.net/)"
+ use_gl="no (requires glew http://glew.sourceforge.net/)"
])
gl_NONPKGCONFIG_LIBS="-lGLEW"
])
+CAIRO_ENABLE_SURFACE_BACKEND(gl_glx, GLX, auto, [
+ if test "x$use_gl" != "xyes"; then
+ use_gl_glx="no (requires --enable-gl)"
+ else
+ gl_glx_BASE=cairo-gl
+ old_CPPFLAGS=$CPPFLAGS
+ CPPFLAGS="$CPPFLAGS $gl_CFLAGS $gl_NONPKGCONFIG_CFLAGS"
+ AC_CHECK_HEADER(GL/glx.h,
+ [],
+ [use_gl_glx="no (requires GLX)"])
+ CPPFLAGS=$old_CPPFLAGS
+ fi
+])
+
+CAIRO_ENABLE_SURFACE_BACKEND(gl_egl, eagle, auto, [
+ if test "x$use_gl" != "xyes"; then
+ use_gl_egl="no (requires --enable-gl)"
+ else
+ gl_egl_BASE=cairo-gl
+ gl_egl_REQUIRES="eagle"
+ PKG_CHECK_MODULES(gl_egl, $gl_egl_REQUIRES, ,
+ [AC_MSG_RESULT(no)
+ use_gl_egl="no (requires eagle)"])
+ fi
+])
+
dnl ===========================================================================
GLITZ_MIN_VERSION=0.5.1