summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChris Wilson <chris@chris-wilson.co.uk>2009-09-05 15:21:50 +0100
committerChris Wilson <chris@chris-wilson.co.uk>2009-09-05 15:21:50 +0100
commit310cebf194919cf3a7c37e724e64962ae47343cc (patch)
tree681f810a1b007b11df7afa10773cb2537657208f /configure.ac
parent9b932d7cd750b9bc61d108c80c4530352d952cfa (diff)
[configure] Add option to disable trace.
Some environments may be broken beyond our capabilities to detect, or maybe the user is just insane and doesn't want to build my nice shiny cairo-trace. Whatever, give them the option to choose: $ ./configure --disable-trace
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 5 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index d1b105ef4..c4b38d89a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -644,9 +644,11 @@ case $host in
;;
esac
-AM_CONDITIONAL(BUILD_TRACE,
- test "x$have_ld_preload" = "xyes" \
- -a "x$have_libz" = "xyes")
+CAIRO_ENABLE(trace, cairo-trace, yes, [
+ if test "x$have_ld_preload" != "xyes" -o "x$have_libz" != "xyes"; then
+ use_trace="no (requires dynamic linker and zlib)"
+ fi
+])
AM_CONDITIONAL(BUILD_SCRIPT, test "x$have_libz" = "xyes")