summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChris Wilson <chris@chris-wilson.co.uk>2008-11-03 11:30:38 +0000
committerChris Wilson <chris@chris-wilson.co.uk>2008-11-03 11:30:38 +0000
commit2c08f3f83b1acd168cd74b300272970658179a0f (patch)
tree3a7def75ff477f547f18b73c7b56f9e050219c3e /configure.ac
parent8fc3d0ffebea5622332327cdef9222486cc85581 (diff)
[trace] Autodetect -lbfd during configure
Stop being lazy and detect libbfd during configure.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index da2f8613e..97a09b6ae 100644
--- a/configure.ac
+++ b/configure.ac
@@ -495,6 +495,16 @@ esac
AM_CONDITIONAL(BUILD_TRACE, test "x$have_ld_preload" = "xyes")
+AC_CHECK_LIB(bfd, bfd_openr,
+ [AC_CHECK_HEADER(bfd.h, [have_bfd=yes],
+ [have_bfd="no (requires binutils-dev)"])],
+ [have_bfd="no (requires binutils-dev)"])
+if test "x$have_bfd" = "xyes"; then
+ AC_DEFINE([HAVE_BFD], [1], [Define to 1 if you have binutils-dev installed])
+ BFD_LIBS=-lbfd
+ AC_SUBST(BFD_LIBS)
+fi
+
dnl ===========================================================================
AC_ARG_ENABLE(some-floating-point,