summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorCarl Worth <cworth@cworth.org>2005-08-12 23:50:17 +0000
committerCarl Worth <cworth@cworth.org>2005-08-12 23:50:17 +0000
commita201637c7224b921948b79e4244dcc4f99f76cdf (patch)
tree56ae2748ac68f253329766c16b2989442f7596b1 /Makefile.am
parent21dff93be5fd8fff1e4de96afaf8ff12cb7a850a (diff)
Move tag from an instruction in RELEASING to an automated step at the end of release-publish.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 5fb29092f..7525ee201 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -58,11 +58,13 @@ release-verify-newer:
&& false)
@echo "Good."
+CVS=cvs
release-publish: release-verify-even-micro release-verify-newer release-check
mkdir -p releases
scp $(tar_file) $(md5_file) $(RELEASE_UPLOAD_HOST):$(RELEASE_UPLOAD_DIR)
mv $(tar_file) $(md5_file) releases
ssh $(RELEASE_UPLOAD_HOST) "rm -f $(RELEASE_UPLOAD_DIR)/LATEST-$(PACKAGE)-[0-9]* && touch $(RELEASE_UPLOAD_DIR)/LATEST-$(PACKAGE)-$(VERSION)"
+ $(CVS) tag RELEASE_$(CAIRO_VERSION_MAJOR)_$(CAIRO_VERSION_MINOR)_$(CAIRO_VERSION_MICRO)
@echo ""
@echo "Please send an announcement to $(RELEASE_ANNOUNCE_LIST)"
@echo "including the following:"