summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorBehdad Esfahbod <behdad@home.(none)>2006-03-15 14:19:08 -0500
committerBehdad Esfahbod <behdad@home.(none)>2006-03-15 15:25:03 -0500
commitf5013b6dc6442493ea38949fdcc137e5c44b6872 (patch)
treec68c9c195fcf42af3dff65639a72586333cc3e82 /Makefile.am
parent46e5ed66d3329f1608950d817e7248c91087893a (diff)
Add a release-publish-message target to only get the message.
(cherry picked from 98facc6c2d0f57f05de7b98c2aaa592c895d1a09 commit)
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 47bedefda..165f9c349 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -145,7 +145,7 @@ release-upload: release-check $(tar_file) $(sha1_file) $(gpg_file)
ssh $(RELEASE_UPLOAD_HOST) "rm -f $(RELEASE_UPLOAD_DIR)/LATEST-$(PACKAGE)-[0-9]* && ln -s $(tar_file) $(RELEASE_UPLOAD_DIR)/LATEST-$(PACKAGE)-$(VERSION)"
git tag -s $(CAIRO_VERSION_MAJOR).$(CAIRO_VERSION_MINOR).$(CAIRO_VERSION_MICRO)
-release-publish: release-upload releases/$(sha1_file)
+release-publish-message: releases/$(sha1_file)
@echo ""
@echo "Please send an announcement to $(RELEASE_ANNOUNCE_LIST)"
@echo "including the following:"
@@ -172,6 +172,8 @@ release-publish: release-upload releases/$(sha1_file)
@echo "Last but not least, do not forget to bump up the micro"
@echo "version component to the next (odd) number and commit."
+release-publish: release-upload release-publish-message
+
# XXX: Depending on all here is rather overkill. We don't really need
# the library built in order to create the documentation.
docs-publish: all