summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorCarl Worth <cworth@cworth.org>2005-10-13 07:30:15 +0000
committerCarl Worth <cworth@cworth.org>2005-10-13 07:30:15 +0000
commitd31d5db04fe5706e26f117def1fffda627ccf8cf (patch)
treea15144aa07800c6a75a0afe82406ac3182e4084a /Makefile.am
parentcd859a23d022d2aa84649e6e076cd75834800263 (diff)
Increment libtool versioning to 5:0:3 in anticipation of 1.2.0 which will add interfaces. The motivation for this is to make the 1.1.1 release install a library which will be considered newer than 1.0.2.
Add a release-verify-soname-major check to verify that the soname major number is always 2 as part of the release-publish target. Reviewed by: otaylor
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 9 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 7d7cb58b3..ab5ca24bf 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -62,6 +62,14 @@ $(developer_zip_file): install
zips: $(runtime_zip_file) $(developer_zip_file)
+release-verify-soname-major:
+ @echo -n "Checking that the cairo soname major number is 2..."
+ @test "$(LT_CURRENT_MINUS_AGE)" = "2" \
+ || (echo "Ouch." && echo "The soname major number is $(LT_CURRENT_MINUS_AGE) instead of 2." \
+ && echo "The libtool shared library version numbers in configure.in must be incremented properly." \
+ && false)
+ @echo "Good."
+
release-verify-even-micro:
@echo -n "Checking that $(VERSION) has an even micro component..."
@test "$(CAIRO_VERSION_MICRO)" = "`echo $(CAIRO_VERSION_MICRO)/2*2 | bc`" \
@@ -89,7 +97,7 @@ release-remove-old:
release-cleanup-group-sticky:
find . -type f | xargs chmod g-s
-release-check: release-verify-even-micro release-verify-newer release-remove-old release-cleanup-group-sticky distcheck
+release-check: release-verify-soname-major release-verify-even-micro release-verify-newer release-remove-old release-cleanup-group-sticky distcheck
release-upload: release-check $(tar_file) $(sha1_file) $(gpg_file)
mkdir -p releases