summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorCarl Worth <cworth@cworth.org>2006-08-31 04:01:10 -0700
committerCarl Worth <cworth@cworth.org>2006-08-31 04:01:10 -0700
commitd1834cca192fe6f8e429be0461fab6914e04024d (patch)
treebae8be8e3f1604d25682131660937c44a19a7e9b /Makefile.am
parentd52a1f762d33f3ada919b581e0d62f8ba1c2314c (diff)
test: Ignore single-bit errors for SVG backend.
The interface of the various buffer/image_diff functions is improved to provide the maximum pixel difference in addition to the number of pixels that differ. This value can then be used to compare against a per-backend tolerance. Currently I've set the SVG backend's tolerance to 1 to handle some issues we're currently seeing of single-bit differences on different systems, (but we're not exactly sure why yet). Also I improved the image_diff routines to properly report a status value on failure rather than the bogus value of -1 for pixels_changed.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index cb4496c12..5f376d4a7 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,4 +1,4 @@
-DIST_SUBDIRS = pixman src test doc
+DIST_SUBDIRS = pixman src boilerplate test doc
SUBDIRS = pixman src doc
.PHONY: doc test retest recheck check-valgrind