summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorOwen Taylor <otaylor@redhat.com>2005-07-28 10:43:27 +0000
committerOwen Taylor <otaylor@redhat.com>2005-07-28 10:43:27 +0000
commit1e66aee352d092cbd39cac196cdf1b3681ec4c17 (patch)
tree5921cf3061faf0416309880189975babac32f924 /Makefile.am
parenta83124a3eeff1602c199a961b36d75a51ce96843 (diff)
configure.in Makefile.am: Skip tests/ directory if libpng was disabled. (#3423, reported by Steve Chaplin)
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 31aea9118..c2a9965a6 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,4 +1,10 @@
-SUBDIRS = src test doc
+DIST_SUBDIRS = src test doc
+SUBDIRS = src doc
+
+# libpng is required for our test programs
+if CAIRO_HAS_PNG_FUNCTIONS
+SUBDIRS += test
+endif
EXTRA_DIST = \
COPYING \