summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorZhigang Gong <zhigang.gong@linux.intel.com>2013-02-26 17:36:53 +0800
committerZhigang Gong <zhigang.gong@linux.intel.com>2013-04-10 14:52:30 +0800
commitc0d17ecc4df00b98b0d9a23c99864e8181c16f17 (patch)
tree7c6967a399891be7fa924b9c96f8120539b6fe12 /CMakeLists.txt
parente67bbed43662ee6c749819e830a17053b4d0e365 (diff)
Implement cl_khr_gl_sharing by using upstream technology.
The previous implementation use a modified mesa library and can't work with upstream mesa. Now I managed to use existing egl extension and gbm to import a gl texture to a cl image. Actually, the gbm can't fully support our purpose, as it can't lookup image for egl x11 platform. We have to touch gbm's internal data structure to manually initialize its image extension. Furthermore, gbm only provide the API to get the image's handle, and doesn't provide the one to get image's name. As we are using different fd from the existing GL loader. The handle is useless for us. I use the DRI2 image extension function directly to get the name rather than the handle. And it works well. Now, after this patch applied. The cl_khr_gl_sharing could work with upstream mesa. I recommend you use the latest git master version. Signed-off-by: Zhigang Gong <zhigang.gong@linux.intel.com> Tested-by: Homer Hsing <homer.xing@intel.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 0 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0297147b..f580ac09 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -119,8 +119,6 @@ ENDIF(GBM_FOUND)
Find_Package(EGL)
IF(EGL_FOUND)
MESSAGE(STATUS "Looking for EGL - found")
- SET(CMAKE_CXX_FLAGS "-DHAS_EGL ${CMAKE_CXX_FLAGS}")
- SET(CMAKE_C_FLAGS "-DHAS_EGL ${CMAKE_C_FLAGS}")
ELSE(EGL_FOUND)
MESSAGE(STATUS "Looking for EGL - not found")
ENDIF(EGL_FOUND)