summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorCosimo Cecchi <cosimoc@gnome.org>2017-07-30 14:41:42 +0100
committerRobert Ancell <robert.ancell@canonical.com>2017-12-20 09:33:21 +1300
commit93e2a85653ca379524c1b912794cff2bf0f3a369 (patch)
tree50016914b41e9aca5197dcd6ff1c72f271cfe163 /configure.ac
parent1ebffd90d0f39964a02dd42e93e71ba5dda3b3bb (diff)
Add support for a list of extra groups for admin users
It's common for distributions to want to add administrator users to additional groups (e.g. lpadmin or systemd-journal); Debian and Ubuntu have patches that add this kind of functionality already. This commit adds a configure option to specify a comma-separated list of extra groups for admin users and adds support for it when both adding a new admin user and promoting an user to admin. https://bugs.freedesktop.org/show_bug.cgi?id=101972
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 4b21477..384f81b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -54,6 +54,11 @@ AS_IF([test x$enable_admin_group = xauto], [
])
AC_DEFINE_UNQUOTED([ADMIN_GROUP], ["$enable_admin_group"], [Define to the group for administrator users])
+AC_ARG_WITH(extra-admin-groups,
+ [AS_HELP_STRING([--with-extra-admin-groups],[Comma-separated list of extra groups that administrator users are part of])],
+ ,with_extra_admin_groups="")
+AC_DEFINE_UNQUOTED([EXTRA_ADMIN_GROUPS], ["$with_extra_admin_groups"], [Define to the list of extra groups administrator users are part of])
+
AC_ARG_ENABLE(user-heuristics,
[AS_HELP_STRING([--enable-user-heuristics],[Enable heuristics for guessing system vs. human users in the range 500-minimum-uid])],
[if test "$enableval" = yes; then
@@ -376,6 +381,7 @@ else
AC_MSG_NOTICE([** DocBook documentation build disabled])
fi
AC_MSG_NOTICE([** Administrator group: $enable_admin_group])
+ AC_MSG_NOTICE([** Extra administrator groups: $with_extra_admin_groups])
echo