summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorColin Walters <walters@verbum.org>2013-03-12 10:18:08 -0400
committerRay Strode <rstrode@redhat.com>2013-03-12 17:34:05 -0400
commit43649abb64811d13dc19e2b1d35987771c7d7727 (patch)
tree0f443bee781a893cc21a6e3b8e8a892662c2c2d8 /configure.ac
parent636d639fc1ba81b769597e2d45d162632f61f2e1 (diff)
Add --enable-admin-group build option
Two major choices are wheel/sudo; that's unlikely to unify anytime soon, so let's make it build-time configurable. https://bugzilla.gnome.org/show_bug.cgi?id=695419 https://bugs.freedesktop.org/show_bug.cgi?id=62235
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac21
1 files changed, 21 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 8360763..6bf8854 100644
--- a/configure.ac
+++ b/configure.ac
@@ -40,6 +40,26 @@ GOBJECT_INTROSPECTION_CHECK([0.9.12])
VAPIGEN_CHECK
+dnl ---------------------------------------------------------------------------
+dnl - Core configuration
+dnl ---------------------------------------------------------------------------
+
+AC_ARG_ENABLE(admin-group,
+ [AS_HELP_STRING([--enable-admin-group],[Set group for administrative accounts @<:@default=auto@:>@])],
+ ,enable_admin_group=auto)
+AS_IF([test x$enable_admin_group = xauto], [
+ AC_CHECK_FILE(/etc/redhat-release, enable_admin_group=wheel)
+ AC_CHECK_FILE(/etc/debian_version, enable_admin_group=sudo)
+ AS_IF([test x$enable_admin_group = xauto], [
+ enable_admin_group=wheel
+ ])
+])
+AC_DEFINE(ADMIN_GROUP, [$enable_admin_group], [Define to the group for administrator users])
+
+dnl ---------------------------------------------------------------------------
+dnl - Warnings
+dnl ---------------------------------------------------------------------------
+
AC_ARG_ENABLE(more-warnings,
AS_HELP_STRING([--enable-more-warnings],
[Maximum compiler warnings]),
@@ -259,6 +279,7 @@ if test "x$enable_docbook_docs" = "xyes"; then
else
AC_MSG_NOTICE([** DocBook documentation build disabled])
fi
+ AC_MSG_NOTICE([** Administrator group: $enable_admin_group])
echo