summaryrefslogtreecommitdiff
path: root/src/platform/tests/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/platform/tests/meson.build')
-rw-r--r--src/platform/tests/meson.build34
1 files changed, 34 insertions, 0 deletions
diff --git a/src/platform/tests/meson.build b/src/platform/tests/meson.build
new file mode 100644
index 0000000000..e8b9ca56b6
--- /dev/null
+++ b/src/platform/tests/meson.build
@@ -0,0 +1,34 @@
+test_units = [
+ ['test-link-fake', 'test-link.c'],
+ ['test-link-linux', 'test-link.c'],
+ ['test-address-fake', 'test-address.c'],
+ ['test-address-linux', 'test-address.c'],
+ ['test-general', 'test-general.c'],
+ ['test-nmp-object', 'test-nmp-object.c'],
+ ['test-route-fake', 'test-route.c'],
+ ['test-route-linux', 'test-route.c'],
+ ['test-cleanup-fake', 'test-cleanup.c'],
+ ['test-cleanup-linux', 'test-cleanup.c'],
+]
+
+foreach test_unit: test_units
+ name = 'platform-' + test_unit[0]
+
+ exe = executable(
+ name,
+ test_unit[1],
+ dependencies: test_core_dep,
+ c_args: test_cflags_platform
+ )
+
+ test(name, exe)
+endforeach
+
+test = 'monitor'
+
+executable(
+ test,
+ test + '.c',
+ dependencies: test_core_dep,
+ c_args: test_cflags_platform
+)