summaryrefslogtreecommitdiff
path: root/src/dnsmasq/tests/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/dnsmasq/tests/meson.build')
-rw-r--r--src/dnsmasq/tests/meson.build12
1 files changed, 12 insertions, 0 deletions
diff --git a/src/dnsmasq/tests/meson.build b/src/dnsmasq/tests/meson.build
new file mode 100644
index 0000000000..4c4173faa0
--- /dev/null
+++ b/src/dnsmasq/tests/meson.build
@@ -0,0 +1,12 @@
+test_unit = 'test-dnsmasq-utils'
+
+cflags = '-DTESTDIR="@0@"'.format(meson.source_root())
+
+exe = executable(
+ test_unit,
+ test_unit + '.c',
+ dependencies: test_core_dep,
+ c_args: cflags
+)
+
+test(test_unit, exe)